Cloud4all Pilot 2 - Set up and installation

From wiki.gpii
Jump to: navigation, search

Notes:


Installing GPII

Fedora Installation Instructions

The second pilots will run on Fedora 20. You can install this using the Fedora 20 Live Desktop ISO Image.

  1. To install Fedora:
    • From a Live CD, choose Applications > System Tools > Install to Hard Drive
    • From an Install ISO, choose Activities > Install to Hard Drive
  2. To install the GPII framework, follow the steps in the GPII on Fedora 20 installation instructions (on Google Drive).

As an alternative, you can also install the GPII on Fedora yourself by following the instructions in Setting Up Your Development Environment, but for the pilots, it is highly recommended to install it by using the RPM packages.

Orca Configuration for Firefox

After installing Fedora, it is a good idea to briefly launch Orca. Going through the configuration for Firefox described below is sufficient for this. (Until Orca is launched for the first time, there is no file with Orca settings at /home/<user>/.local/share/orca/user-settings.conf; the orca directory is created when Orca is started for the first time.)

Make sure that caret navigation when using Firefox with Orca is handled by Orca. First start Orca, then start Firefox. While you are in Firefox, press Ctrl+Orca Modifier+Space (on a desktop PC, the Orca modifier is usually the Insert key, so you should press Ctrl+Insert+Space). You should then see the Orca settings dialog with a Firefox tab. On this tab, disable the first setting: "Control caret navigation". (See this dialog.)

Logging on Fedora

The scripts for logging facilities are included in the RPMs for Fedora 20. You can execute the logging of the current settings, user, etc. via the pilotsConfig tool by clicking on the button "logging". This will save a log file to your local system, per default to /home/<your_username>/gpiilogs_pilot2/

You can also call the logging from the command line: open a terminal and enter LogLocalSettings. (This command is case sensitive.)

Windows Installation Instructions

For the second pilots, Windows 7, 64 bit will be used. The OS should be installed with Aero Themes (in order to enable lens mode and full screen mode in the Magnifier).

Dependencies

  • Git
    • Install GitHub for Windows - it includes the command line Msysgit.
    • Be sure to choose "Run Git from the Windows Command Prompt" on the "Adjusting your PATH environment" panel.
    • (OR, for advanced developers, use Cygwin for a full Unix-like environment on Windows.)

Building and Starting the GPII Personalization Framework on Windows

  • Open a command line (Start > Run > cmd.exe)
  • Create a GPII directory
    • mkdir c:\gpii (or wherever you prefer, but the rest of the instructions assume C:\gpii)
    • cd c:\gpii
  • Clone the GPII Windows repository
    • git clone git://github.com/GPII/windows.git
    • cd windows
  • Compile the GPII Windows native code (run the following command from the Windows/DOS shell):
    • build.cmd
  • Check out the pilots 2 branch of universal
    • cd c:\gpii\node_modules\universal
    • git fetch origin
    • git checkout pilots2
  • Start the GPII Framework and the USB Listener (from the Windows/DOS shell - not the Git Bash shell - while in the gpii\windows folder):
    • cd C:\gpii\windows
    • start.cmd (However, another script for starting GPII is mentioned below.)

NOTE: The pilots are expected to run with the pilot2 configuration, i.e. using the "pilotsConfig tool" (see below). This will happen automatically if you use the desktop script from below. Else you will have to set it via "SET NODE_ENV=pilot2" on the command line in which "node gpii.js" is executed

Additional Windows Configuration

  • On Windows 7, the GPII cannot kill applications using taskill unless you change the user account control settings:
    • Go into Control Panels > User Accounts and Family Safety > User Accounts > User Account Control Settings
    • Set the notification level to "Never notify".
    • You need to reboot Windows to apply this setting.
  • The Magnifier may be set to change magnification in steps of 100% by default. In order to enable smaller steps, start the Magnifier, open the Options (the cogwheel icon) and change the slider to 25%.
  • The following is optional but useful if you want to report back on bugs:
    • Open a command line and right-click on the command line's window.
    • In the context menu that pops up, select the "Layout" tab.
    • In the layout tab, change the "Height" of the "Screen Buffer Size" to a much higher number, e.g. 900. Then click OK to confirm the change.
    • As a result of this, most of the DOS windows that pop up when you start GPII will "store" more logging lines. These logging lines can be copied and pasted into bug reports. For guidance on how to copy those logging lines, see Microsoft's article To copy text from a command prompt window.

Installing the RFID/NFC user listener

Notes:

  • Avira (or at least its free version) issues a virus warning when you save GpiiUserListener110.exe to your hard disk. This virus warning is triggered again and again, even after telling Avira to ignore the warning. Until further notice, you need to use a different antivirus program to work with this RFID/NFC listener.
  • Due to an issue with the RFID listener on Windows (see JIRA ticket GPII-715), the steps below are currently not relevant.

Installing the shortcut for running GPII

  • Download gpii_ctrl.bat.
  • Save it anywhere you want. (We suggest the desktop.)
  • To start GPII, double click this file or run it from the command line as: gpii_ctrl.bat. To stop GPII, use the command gpii_ctrl.bat kill.

Note:

  • This script can only run when you have also installed the pilotsConfig tool (see below) in the same directory (on Windows: C:\gpii\).
  • This script assumes that you installed GPII in C:\gpii (as in the instructions above). If you installed GPII elsewhere, you will need to adapt the line SET GPII_INSTALL_DIR=C:\gpii so it reflects the directory where GPII is installed.

Logging on Windows

Download the following script for logging

and save it to the windows folder of your GPII installation (usually C:\GPII\windows).

After downloading this file, you will have two ways to execute the logging of the current user's settings:

  • Via the pilotsConfig tool (see installation instructions below) by clicking on the button "logging". This will save a log file to your local system, per default to C:\gpiilogs_pilot2.
  • Alternatively, you can create a shortcut to the file LogLocalSettings.cmd to execute it. To do this, open the windows folder of your GPII installation using the file explorer (eg. click the Windows "Start" button, then browse to C:\GPII\windows). Then drag the LogLocalSettings.cmd file to the desktop and hold in the "Alt" key while dropping it on the desktop. Make sure that you have created a shortcut and not just moved the file. From this point on a log can be triggered by double clicking the desktop icon.

Updating your Windows install

If changes has been made to any of the core code, you need to update the code on your machine.

First thing that needs to be done is to update universal. Go to the node_modules/universal folder of your GPII install dir:

cd C:\gpii\node_modules\universal

Update your references and pull latest code in:

git fetch origin
git merge origin/pilots2

Update the dependencies. This may not always be necessary, but do it if you want to be on the safe side. First you need to delete the "node_modules" folder from inside universal:

cd C:\gpii\node_modules\universal
rmdir node_modules /S /q
npm install

The next step is to update the Windows part of the code: go to the windows directory, update the references and pull in the latest code:

cd C:\gpii\windows
git fetch origin
git merge origin/master

Android Installation Instructions

Available here https://docs.google.com/document/d/1P0ZNgu6peGcIYK1tPVOwW-EKE9hfTUgNCuJegm7nTn4/edit?usp=sharing

Troubleshooting

Once you start the system (by using the start.cmd/start.sh scripts), you can test it without USB by navigating your browser to the following URLs:

http://localhost:8081/user/sammy/login

http://localhost:8081/user/sammy/logout


Windows build (build.cmd) errors

The Windows build script (build.cmd) sometimes causes errors. If this happens, you need to delete the folder npm-cache which is located in C:\Users\[USER]\AppData\Roaming (aka %APPDATA%).

You should also avoid renaming this folder by extending its name to e.g. npm-cache-old because this would still cause build errors. This build issue may occur when you install the GPII framework on a Windows computer where an older version of GPII was installed in the past.


Git instead of https

If you have problems running the git clone commands due to the git:// protocol (e.g. because of firewalls or the like) you can run the following command:

git config --global url."https://".insteadOf git://

Reporting problems found during tests

Problems found during end-to-end testing and prepilots are listed at Pilot phase 2 problems. This page also contains references to the relevant JIRA tickets, if any exist.

Installing the PMT/PCP

See Running the PMT & PCP on Windows and Linux with a local web server.

Updating the PMT and PCP

Go to the installation directory, update the references and pull in the latest code:

cd C:\gpii\prefsEditors
git fetch origin
git merge origin/master

Note: Since "platform A" in the tests will always be Windows, the update instructions for Linux are not mentioned here.

Installing the pilotsConfig tool

The pilotsConfig tool supports test facilitators by performing the following tasks:

  • Selecting matchmakers.
  • Setting device reporter data.
  • Snapshotting settings and saving them as preferences to the Preference Server.
  • Select feedback pages for the scenario "Proposing a new Solution"

Clone the pilotsConfig repository into the root directory of your Cloud4all/GPII installation on the same level as the Windows/Linux and node_modules, so you have a directory structure like the following:

  /gpii
    /node_modules
    /windows
    /pilotsConfig

Git command to clone the repository:

cd [your path to GPII/Cloud4all root directory]
git clone https://github.com/Cloud4AllTUD/pilotsConfig.git

Usage:

  1. Launch the GPII/Cloud4all personalisation server on your device (see above)
  2. Launch the application pilotsConfig by running startOnWindows.cmd (Windows) or ./startOnLinux.sh (Linux) in the folder pilotsConfig.
    • On Linux, you can also start the pilotsConfig tool by opening a terminal and entering gpii-pilotsConfig.
  3. Open a browser and open the following link: http://localhost:8888/start.

Updating the pilotsConfig tool

Go to the installation directory, update the references and pull in the latest code:

cd C:\gpii\pilotsConfig
git fetch origin
git merge origin/master

(If you want to update the pilotsConfig tool on Fedora, see the GPII installation instructions for Fedora.)

Logging the current settings

Both on Windows and Linux, logging the current settings can be done using the "Log" button in the pilotsConfig tool or using the command line scripts (see above).

Snapshotting the current settings to preferences

Saving the current settings to the Preferences Server can be done using the "Snapshot" button in the pilotsConfig tool.

Adding browser bookmarks

It is useful to add bookmarks for the following tools or sites to Firefox (and possibly Chrome), so they are always within reach during the tests:

For example, you can create a "Cloud4all" folder on the bookmarks folder in Firefox and add the bookmarks there. If the bookmarks toolbar is not visible (Firefox 29 hides it by default), click the menu button (in the top right corner) and choose "Customize". Then open the "Show/Hide Toolbars" dropdown menu and select "Bookmarks toolbar". Finally, click the green "Exit customize" button. You can now add folders and bookmarks to the bookmarks toolbar. (See also Mozilla support: Bookmarks Toolbar.) In older versions of Firefox (e.g. on Fedora 20), go to View > Toolbars and enable the bookmarks toolbar.

SP3 solutions details

Installation instructions for SP3 solutions are described in https://docs.google.com/document/d/1OBiWpRJGEH8yNfy_5lHD2RzvD_D6imCZZQ8zxePDZQE/.


Wiki Categories